Banner, MyAccount, and Timecard are down

Incident Report for Biola University

Resolved

This incident has been resolved.
Posted Dec 09, 2025 - 12:31 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 09, 2025 - 11:45 PST

Investigating

IT is currently investigating the issue.
Posted Dec 09, 2025 - 11:16 PST
This incident affected: Administrative Services (Banner), Academic Services (My Account), and Campus Services (Timecard).